]> Pileus Git - ~andy/sunrise/blob - x11-drivers/nostromo_n50/nostromo_n50-1.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / x11-drivers / nostromo_n50 / nostromo_n50-1.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils linux-info
6
7 DESCRIPTION="Configuration GUI for Belkin Nostromo n50/n52 speedpads."
8 HOMEPAGE="http://sf.net/projects/nostromodriver"
9 SRC_URI="mirror://sourceforge/nostromodriver/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14 RDEPEND="x11-libs/libXft
15         x11-libs/libXtst
16         dev-libs/libxml2
17         x11-libs/gtk+"
18 DEPEND="${RDEPEND}
19         x11-proto/xproto
20         x11-libs/fltk
21         x11-proto/xextproto"
22 CONFIG_CHECK="INPUT_EVDEV"
23
24 src_install() {
25         einstall || die "einstall failed"
26         insinto /etc/udev/rules.d
27         doins "${FILESDIR}/60-nostromo.rules"
28
29         make_desktop_entry nostromo_config "Nostromo Configuration" n50_tray.png "System"
30         make_desktop_entry nostromo_daemon "Nostromo Daemon" n50_tray.png "System"
31 }