]> Pileus Git - ~andy/sunrise/blob - www-client/uzbl/uzbl-9999.ebuild
40b5a4db3b68262957e3ec2f9ef7197a2e41ce31
[~andy/sunrise] / www-client / uzbl / uzbl-9999.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 EGIT_REPO_URI="git://github.com/Dieterbe/uzbl.git"
8
9 inherit git toolchain-funcs
10
11 DESCRIPTION="A web browser that follows the UNIX philosophy"
12 HOMEPAGE="http://www.uzbl.org"
13 SRC_URI=""
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 RDEPEND="dev-lang/perl
21         gnome-extra/zenity
22         net-misc/socat
23         >=net-libs/libsoup-2.24
24         >=net-libs/webkit-gtk-1.1.4
25         >=x11-libs/gtk+-2.14"
26 DEPEND="${RDEPEND}
27         dev-util/pkgconfig"
28
29 EGIT_PATCHES=("${FILESDIR}/${PV}-Makefile.patch")
30
31 src_compile() {
32         emake CC=$(tc-getCC) || die "emake failed"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die "install failed"
37         dodoc docs/* || die "dodoc failed"
38 }
39
40 pkg_postinst() {
41         ewarn "Remember to export XDG_DATA_HOME and XDG_CONFIG_HOME or otherwise"
42         ewarn "${PN} won't work."
43         ewarn "For testing do:"
44         ewarn " export XDG_DATA_HOME=\"/usr/share/uzbl/examples/data/\""
45         ewarn " export XDG_CONFIG_HOME=\"/usr/share/uzbl/examples/config/\""
46 }