]> Pileus Git - ~andy/sunrise/blob - www-apps/phpMyProxy/phpMyProxy-1.0.3.ebuild
games-strategy/freesynd: in main tree
[~andy/sunrise] / www-apps / phpMyProxy / phpMyProxy-1.0.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit webapp depend.php
8
9 DESCRIPTION="phpMyProxy is a web-based proxy script in PHP"
10 HOMEPAGE="http://www.phpmyproxy.com/"
11 # Upstream hosts source files as an attachment in a _password protected forum_
12 SRC_URI="http://omploader.org/vejZx/${P/-/_}.zip"
13
14 LICENSE="GPL-3"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="app-arch/unzip
19         dev-lang/php[curl]"
20 RDEPEND=""
21
22 S=${WORKDIR}/${P/-/_}
23
24 need_php_httpd
25 need_httpd_cgi
26
27 src_install() {
28         webapp_src_preinst
29
30         dodoc README.txt TODO.txt CHANGELOG.txt || die "Cannot copy documentation"
31         rm -f README.txt TODO.txt CHANGELOG.txt UPGRADE.txt \
32                 || die "Cannot delete copied documentattion"
33
34         insinto "${MY_HTDOCSDIR}"
35         doins -r .  || die "Cannot copy program files"
36         keepdir "${MY_HTDOCSDIR}"/cookies || die "Cannot create cookies directory"
37
38         webapp_serverowned "${MY_HTDOCSDIR}"/cookies
39         webapp_serverowned "${MY_HTDOCSDIR}"/curl_log.txt
40
41         webapp_configfile "${MY_HTDOCSDIR}"/proxy.config.php
42
43         #webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
44         #webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
45
46         webapp_src_install
47 }