]> Pileus Git - ~andy/sunrise/blob - www-apps/modx/modx-1.0.4.ebuild
app-editors/yzis: Fix qt deps, EAPI bump
[~andy/sunrise] / www-apps / modx / modx-1.0.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit webapp
8
9 DESCRIPTION="The Ajax CMS for today. And tomorrow"
10 HOMEPAGE="http://modxcms.com/"
11 SRC_URI="http://modxcms.com/download/ga/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 RDEPEND="virtual/httpd-cgi
18         >=virtual/mysql-4.1
19         || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
20
21 src_install() {
22         webapp_src_preinst
23         find -name ht.access -exec sh -c \
24                 'f="{}"; mv "${f}" "${f%ht.access}.htaccess"' \; \
25                 || die "Dot fix failed"
26         insinto ${MY_HTDOCSDIR}
27         doins -r . || die "Instalation failed"
28         webapp_src_install
29 }