]> Pileus Git - ~andy/sunrise/blob - www-apache/mod_authn_otp/mod_authn_otp-1.1.4.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / www-apache / mod_authn_otp / mod_authn_otp-1.1.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit apache-module
8
9 DESCRIPTION="An Apache module for two-factor authentication (HOTP/OATH)"
10 HOMEPAGE="http://code.google.com/p/mod-authn-otp/"
11 SRC_URI="http://mod-authn-otp.googlecode.com/files/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 APACHE2_MOD_CONF="70_${PN}"
19 APACHE2_MOD_DEFINE="AUTHN_OTP"
20
21 DOCFILES="README users.sample CHANGES"
22
23 need_apache2
24
25 src_compile() {
26         default
27 }
28
29 src_install() {
30         apache-module_src_install
31         doman otptool.1 || die "doman failed"
32         dobin otptool || die "dobin failed"
33 }
34
35 pkg_postinst(){
36         apache-module_pkg_postinst
37         elog "For configuration information see:"
38         elog "  http://code.google.com/p/mod-authn-otp/wiki/Configuration"
39 }