]> Pileus Git - ~andy/sunrise/blob - sys-process/ts/ts-0.6.6.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / sys-process / ts / ts-0.6.6.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="TaskSpooler is a comfortable way of running batch jobs"
8 HOMEPAGE="http://vicerveza.homeunix.net/~viric/soft/ts/"
9 SRC_URI="http://vicerveza.homeunix.net/~viric/soft/ts/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 src_unpack() {
16         unpack ${A}
17         cd "${S}"
18
19         sed -i \
20                 -e 's|CFLAGS=|CFLAGS+=|' \
21                 -e 's|-g -O0||' \
22                 Makefile || die "sed failed"
23 }
24
25 src_compile() {
26         emake CC=$(tc-getCC) || die "emake failed"
27 }
28
29 src_install() {
30         emake PREFIX="${D}/usr" install || die "install failed"
31         dodoc Changelog OBJECTIVES PORTABILITY PROTOCOL README TRICKS || die
32 }
33
34 src_test() {
35         PATH="${D}/usr/bin:${PATH}" ./testbench.sh || die "tests failed"
36 }