]> Pileus Git - ~andy/sunrise/blob - sys-process/nmon/nmon-13g.ebuild
d8f4d248b22c5cb34697c697ae8bf2d6ed555356
[~andy/sunrise] / sys-process / nmon / nmon-13g.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="Nigel's Monitor - provided by IBM"
10 HOMEPAGE="http://nmon.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/lmon${PV}.c"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="sys-libs/ncurses"
19 RDEPEND="${DEPEND}"
20
21 src_unpack() {
22         cp "${DISTDIR}"/lmon${PV}.c "${WORKDIR}"/lmon.c || die "cp failed"
23         cp "${FILESDIR}/${P}_makefile" "${WORKDIR}"/makefile || die "cp failed"
24 }
25
26 src_compile() {
27         emake CC="$(tc-getCC)" || die "emake failed"
28 }
29
30 src_install() {
31         dobin nmon || die "dobin failed"
32 }