]> Pileus Git - ~andy/sunrise/blob - sys-power/yacpi/yacpi-3.0.1.ebuild
app-backup/rdup: Reorder variables according to CodingStandards
[~andy/sunrise] / sys-power / yacpi / yacpi-3.0.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Yet Another Configuration and Power Interface"
10 HOMEPAGE="http://www.ngolde.de/yacpi.html"
11 SRC_URI="http://www.ngolde.de/download/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="sys-libs/libacpi
19         sys-libs/ncurses"
20 DEPEND="${RDEPEND}"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${PV}-Makefile.patch
24 }
25
26 src_compile() {
27         emake \
28                 CC=$(tc-getCC) || \
29                 die "emake failed"
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || \
34                 die "installation failed"
35 }