]> Pileus Git - ~andy/sunrise/blob - sys-power/powerthend/powerthend-1.1.1.ebuild
app-accessibility/julius: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / sys-power / powerthend / powerthend-1.1.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="Daemon to control the speed and voltage of CPUs"
8 HOMEPAGE="http://powerthend.scheissname.de/"
9 SRC_URI="http://dev.gentooexperimental.org/~tommy/distfiles/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 src_prepare() {
17         sed -i "s:-O2:${CFLAGS}:" Makefile
18 }
19
20 src_compile() {
21         emake powerthend || die "emake failed"
22 }
23
24 src_install() {
25         dosbin powerthend || die "dosbin failed"
26         dodoc README || die "dodoc failed"
27
28         newconfd "${FILESDIR}/powerthend.confd" powerthend
29         newinitd "${FILESDIR}/powerthend.rc" powerthend
30 }