]> Pileus Git - ~andy/sunrise/blob - sys-power/phc-intel/phc-intel-0.3.2.11.ebuild
sys-power/phc-intel: Re-added version 0.3.2.10 for kernels before 2.6.33, support...
[~andy/sunrise] / sys-power / phc-intel / phc-intel-0.3.2.11.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit linux-info linux-mod
8
9 DESCRIPTION="Processor Hardware Control for Intel CPUs"
10 HOMEPAGE="http://www.linux-phc.org/"
11 SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=92 -> ${P}.tar.bz2
12         http://xmw.de/mirror/${PN}/${P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 S="${WORKDIR}/${P%.*}-${P##*.}"
20
21 CONFIG_CHECK="~!X86_ACPI_CPUFREQ"
22 ERROR_X86_ACPI_CPUFREQ="CONFIG_X86_ACPI_CPUFREQ has to be configured to Module or Not set to enable the replacement of acpi-cpufreq with phc-intel."
23
24 MODULE_NAMES="phc-intel(misc:)"
25 BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
26 BUILD_TARGETS="prepare all"
27
28 pkg_setup() {
29         if kernel_is lt 2 6 33 ; then
30                 eerror "Your kernel version is no longer supported by this version of ${PN}."
31                 eerror "Please use a previous version of ${PN} or a newer kernel."
32                 die
33         fi
34 }
35
36 src_install() {
37         linux-mod_src_install
38         dodoc README || die
39 }