]> Pileus Git - ~andy/sunrise/blob - sys-power/phc-intel/phc-intel-0.3.2.10.ebuild
560ccbefe599d075847ced10dddea748d6e614e0
[~andy/sunrise] / sys-power / phc-intel / phc-intel-0.3.2.10.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit linux-info linux-mod
8
9 DESCRIPTION="Processor Hardwae Control for Intel CPUs"
10 HOMEPAGE="http://www.linux-phc.org/"
11 SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=87 -> ${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 S="${WORKDIR}/${P%.*}-${P##*.}"
19
20 CONFIG_CHECK="!CONFIG_X86_ACPI_CPUFREQ"
21 ERROR_CONFIG_X86_ACPI_CPUFREQ="CONFIG_X86_ACPI_CPUFREQ has to be set to Module or Not set to enable the replacement of acpi-cpufreq with phc-intel."
22
23 MODULE_NAMES="phc-intel(misc:)"
24 BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\""
25 BUILD_TARGETS="prepare all"
26
27 src_prepare() {
28         if kernel_is -ge 2 6 33 ; then
29                 sed -i -e "s:include/linux/utsrelease.h:include/generated/utsrelease.h:" Makefile || die
30         fi
31 }