]> Pileus Git - ~andy/sunrise/blob - sys-libs/libacpi/libacpi-0.2.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / sys-libs / libacpi / libacpi-0.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="general purpose shared library for programs gathering ACPI data on Linux"
10 HOMEPAGE="http://ngolde.de/libacpi.html"
11 SRC_URI="http://ngolde.de/download/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 src_prepare() {
19         epatch "${FILESDIR}"/${PV}-config.patch
20         epatch "${FILESDIR}"/${PV}-Makefile.patch
21 }
22
23 src_compile() {
24         emake \
25                 CC=$(tc-getCC) || \
26                 die "emake failed"
27 }
28
29 src_install () {
30         emake DESTDIR="${D}" install || \
31                 die "install failed"
32         dodoc AUTHORS CHANGES README || die "nothing to read"
33         if use doc; then
34                 dohtml doc/html/* || die " no docs"
35         fi
36 }