]> Pileus Git - ~andy/sunrise/blob - sys-kernel/ccs-sources/ccs-sources-2.6.33-r3.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / sys-kernel / ccs-sources / ccs-sources-2.6.33-r3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 ETYPE="sources"
6 K_WANT_GENPATCHES="base extras"
7 K_GENPATCHES_VER="4"
8
9 inherit eutils kernel-2
10 detect_version
11 detect_arch
12
13 CCS_TGP="ccs-patch-1.7.2-20100804"
14 CCS_TGP_SRC="mirror://sourceforge.jp/tomoyo/43375/${CCS_TGP}.tar.gz"
15
16 DESCRIPTION="TOMOYO Linux sources for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
17 HOMEPAGE="http://tomoyo.sourceforge.jp/index.html.en"
18 SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CCS_TGP_SRC}"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21 RDEPEND="sys-apps/ccs-tools"
22
23 K_EXTRAEINFO="Before booting with TOMOYO enabled kernel, you need to
24 run this command to initialize TOMOYO policies:
25 # /usr/lib/ccs/init_policy.sh"
26
27 src_unpack() {
28         kernel-2_src_unpack
29
30         cd "${WORKDIR}"
31         unpack "${CCS_TGP}.tar.gz"
32         cp -dpR security include "${S}" || die
33
34         if [ -f "${FILESDIR}/${PF}.patch" ]; then
35                 cd "${WORKDIR}/patches/"
36                 epatch "${FILESDIR}/${PF}.patch"
37         fi
38
39         cd "${S}"
40         epatch "${WORKDIR}/patches/ccs-patch-${PV}.diff"
41 }