]> Pileus Git - ~andy/sunrise/blob - sys-fs/tdu/tdu-2008.05.07.ebuild
sys-fs/tdu: sys-fs/tdu added
[~andy/sunrise] / sys-fs / tdu / tdu-2008.05.07.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit versionator base toolchain-funcs
6
7 MY_P="${PN}-$(replace_all_version_separators - ${PV})"
8
9 DESCRIPTION="terminal program that displays disk space utilization in an interactive full-screen folding outline"
10 HOMEPAGE="http://webonastick.com/tdu/"
11 SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="sys-libs/ncurses
19         dev-libs/glib"
20 DEPEND="${RDEPEND}
21         dev-util/pkgconfig"
22 S="${WORKDIR}"/${PN}
23
24 PATCHES=( "${FILESDIR}"/${PV}-DESTDIR.patch )
25
26 src_compile() {
27         emake \
28                 CC=$(tc-getCC) || \
29                 die "compilation failed"
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "installation failed"
34         dodoc README TODO || die "nothing to read"
35 }