]> Pileus Git - ~andy/sunrise/blob - sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
dev-python/pottymouth: Either use SUPPORT_PYTHON_ABIS/RESTRICT_PYTHON_ABIS or PYTHON_...
[~andy/sunrise] / sys-fs / ntfs3g-ar / ntfs3g-ar-2009.4.4_pre16.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 MY_P=${PN/3g-ar/-3g}-${PV/_pre/AR.}
8
9 DESCRIPTION="NTFS-3G variant supporting ACLs, junction points, compression and more"
10 HOMEPAGE="http://pagesperso-orange.fr/b.andre/advanced-ntfs-3g.html"
11 SRC_URI="http://pagesperso-orange.fr/b.andre/${MY_P}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug hal suid"
17
18 RDEPEND="hal? ( sys-apps/hal )
19         sys-fs/fuse
20         !sys-fs/ntfs3g"
21 DEPEND="${RDEPEND}"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_configure() {
26         econf \
27                 --docdir="/usr/share/doc/${PF}" \
28                 --enable-ldscript \
29                 --disable-ldconfig \
30                 --with-fuse=external \
31                 $(use_enable debug)
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die "install failed"
36
37         prepalldocs || die "prepalldocs failed"
38         dodoc AUTHORS ChangeLog CREDITS || die "dodoc failed"
39
40         if use suid; then
41                 fperms u+s "/bin/${PN/3g-ar/-3g}" || die "could not change file permisions"
42         fi
43
44         if use hal; then
45                 insinto /etc/hal/fdi/policy/
46                 newins "${FILESDIR}/10-ntfs3g.fdi.2009" "10-ntfs3g.fdi" || die "installation of 10-ntfs3g.fdi.2009 failed"
47         fi
48 }
49
50 pkg_postinst() {
51         ewarn "This is an advanced features release of the ntfs-3g package. It"
52         ewarn "passes standard tests on i386 and x86_64 CPUs but users should"
53         ewarn "still backup their data.  More info at:"
54         ewarn "http://pagesperso-orange.fr/b.andre/advanced-ntfs-3g.html"
55
56         if use suid; then
57                 ewarn
58                 ewarn "You have chosen to install ntfs-3g with the binary setuid root. This"
59                 ewarn "means that if there any undetected vulnerabilities in the binary,"
60                 ewarn "then local users may be able to gain root access on your machine."
61         fi
62 }