]> Pileus Git - ~andy/sunrise/blob - sys-fs/fuseiso/fuseiso-20070708-r1.ebuild
sys-fs/fuseiso: New ebuild fixing issues with large isos as described in msg 17 in...
[~andy/sunrise] / sys-fs / fuseiso / fuseiso-20070708-r1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="FUSE module to mount ISO9660 images"
8 SRC_URI="http://ubiz.ru/dm/${P}.tar.bz2"
9 HOMEPAGE="http://apps.sourceforge.net/mediawiki/fuse/index.php?title=FuseIso"
10
11 LICENSE="GPL-2"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14 SLOT="0"
15
16 DEPEND=">=sys-fs/fuse-2.2.1
17         >=dev-libs/glib-2.4.2"
18 RDEPEND=${DEPEND}
19
20 src_unpack () {
21         unpack ${A}
22
23         # applying patch from Red Hat bug 440436
24         # https://bugzilla.redhat.com/show_bug.cgi?id=440436
25         EPATCH_OPTS="-d ${S}"
26         EPATCH_SINGLE_MSG="Applying bug fix to access content in large ISO files"
27         epatch "${FILESDIR}/${P}-largerthan4gb.patch"
28 }
29
30 src_install () {
31         emake DESTDIR="${D}" install || die "emake install failed"
32         dodoc README NEWS ChangeLog AUTHORS
33 }