]> Pileus Git - ~andy/sunrise/blob - sys-fs/ext3grep/ext3grep-0.10.0.ebuild
sys-fs/aufs: Typo
[~andy/sunrise] / sys-fs / ext3grep / ext3grep-0.10.0.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="recover deleted files on an ext3 file system"
8 HOMEPAGE="http://www.xs4all.nl/~carlo17/howto/undelete_ext3.html"
9 SRC_URI="http://ext3grep.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12
13 SLOT="0"
14 KEYWORDS="~x86"
15
16 IUSE="debug largefile libcwd mmap pch"
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         debug? ( libcwd? ( dev-cpp/libcwd ) )"
20
21 src_unpack(){
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}"/gcc-4.3.patch
25 }
26
27 src_compile() {
28         local myconf
29
30         use debug && myconf="--disable-optimize"
31
32         econf \
33                 $(use_enable libcwd) \
34                 $(use_enable debug) \
35                 ${myconf} \
36                 $(use_enable pch) \
37                 $(use_enable largefile) \
38                 $(use_enable mmap)
39
40         emake || die "emake failed"
41 }
42
43
44 src_install() {
45         emake DESTDIR="${D}" install || die
46
47         dodoc NEWS README || die
48 }