]> Pileus Git - ~andy/sunrise/blob - sys-fs/clamfs/clamfs-1.0.0.ebuild
8701541ea7b027edf9f2933b3eff3e9a84a4bff5
[~andy/sunrise] / sys-fs / clamfs / clamfs-1.0.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A FUSE filesystem for Linux with on-access file scanning through clamd daemon"
8 HOMEPAGE="http://clamfs.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="sys-fs/fuse
17         dev-cpp/commoncpp2
18         dev-libs/rlog
19         dev-libs/poco"
20 RDEPEND="${DEPEND}"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         epatch "${FILESDIR}/${P}-invalid_conversion.patch"
26 }
27 src_install() {
28         emake install DESTDIR="${D}" || die "make install failed"
29         dodoc AUTHORS ChangeLog README || die "dodoc failed"
30         insinto /etc/${PN}
31         newins doc/clamfs.xml clamfs.xml.example || die "newins failed"
32 }