]> Pileus Git - ~andy/sunrise/blob - sys-cluster/clusterit/clusterit-2.4.ebuild
a55638f6ef55bef9a0d66e5b11fd4534aff8c4ed
[~andy/sunrise] / sys-cluster / clusterit / clusterit-2.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="A collection of tools for executing commands on cluster nodes"
6 HOMEPAGE="http://clusterit.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
8
9 LICENSE="BSD"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE="X"
13
14 DEPEND="X? ( x11-libs/libX11 )"
15 RDEPEND="${DEPEND}
16         !app-shells/dsh"
17
18 src_unpack() {
19         unpack ${A}
20         use X || sed -i '/^SUBDIRS =/ { s/dvt//; s/rvt// }' "${S}/Makefile.in"
21 }
22
23 src_install() {
24         emake DESTDIR="${D}" install || die "Install failed"
25         dodoc README CHANGES
26 }