]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_skey/pam_skey-1.1.4.ebuild
sys-auth/pam_skey: move big patch to gentooexperimental.org to fix repoman errors
[~andy/sunrise] / sys-auth / pam_skey / pam_skey-1.1.4.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils pam
6
7 DESCRIPTION="pam interface to existing S/Key library/interface"
8 HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
9 SRC_URI="http://kreator.esa.fer.hr/projects/tarballs/${P}.tar.gz
10         http://gentooexperimental.org/~genstef/dist/${P}-gentoo.patch.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND=">=sys-libs/pam-0.78-r3
18         >=app-admin/skey-1.1.5-r4"
19 RDEPEND="${DEPEND}"
20
21 S="${WORKDIR}/${PN}"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         epatch "${WORKDIR}/${P}-gentoo.patch"
27 }
28
29 src_compile() {
30         econf --libdir="/$(get_libdir)" || die "econf failed"
31         emake || die "emake failed"
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install || die "install failed"
36         dodoc README INSTALL
37         newpamd "${FILESDIR}/pam_skey-system-auth.pam.d" system-auth
38 }