]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_skey/pam_skey-1.1.4.ebuild
sys-auth/pam_skey - add quoting
[~andy/sunrise] / sys-auth / pam_skey / pam_skey-1.1.4.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils pam
6
7 DESCRIPTION="pam interface to existing S/Key library/interface"
8 HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
9 SRC_URI="http://kreator.esa.fer.hr/projects/tarballs/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=">=sys-libs/pam-0.78-r3
17         >=app-admin/skey-1.1.5-r4"
18 RDEPEND="${DEPEND}"
19
20 S="${WORKDIR}/${PN}"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         epatch "${FILESDIR}/${P}-gentoo.patch" || die "patch failed"
26 }
27
28 src_compile() {
29         econf --libdir="/$(get_libdir)" || die "econf failed"
30         emake || die "emake failed"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "install failed"
35         dodoc README INSTALL
36         newpamd "${FILESDIR}/pam_skey-system-auth.pam.d" system-auth
37 }