]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_skey/pam_skey-1.1.4.ebuild
Add echangelog svn changes to the sunrise overlay, bug 136048
[~andy/sunrise] / sys-auth / pam_skey / pam_skey-1.1.4.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils pam
6
7 qevcqejfnv
8 DESCRIPTION="pam interface to existing S/Key library/interface"
9 HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
10 SRC_URI="http://kreator.esa.fer.hr/projects/tarballs/${P}.tar.gz"
11         #http://dchurch.ath.cx/${P}-gentoo-${PR}.patch.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16 DEPEND=">=sys-libs/pam-0.78-r3
17         >=app-admin/skey-1.1.5-r4"
18 S=${WORKDIR}/${PN}
19
20 src_unpack() {
21         unpack ${A}
22         cd ${S}
23         epatch ${FILESDIR}/${P}-gentoo.patch
24 }
25
26 src_compile() {
27         econf --libdir="/lib" || die "econf failed"
28         emake || die "emake failed"
29 }
30
31 src_install() {
32         make DESTDIR=${D} install || die
33         dodoc README INSTALL
34         newpamd ${FILESDIR}/pam_skey-system-auth.pam.d system-auth
35 }