]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_skey/pam_skey-1.1.4-r1.ebuild
sys-auth/pam_skey: Stop mangling /etc/pam.d/system-auth
[~andy/sunrise] / sys-auth / pam_skey / pam_skey-1.1.4-r1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="latest"
6 inherit eutils pam autotools
7
8 DESCRIPTION="pam interface to existing S/Key library/interface"
9 HOMEPAGE="http://freshmeat.net/projects/pam_skey/"
10 SRC_URI="http://kreator.esa.fer.hr/projects/tarballs/${P}.tar.gz
11         http://gentooexperimental.org/~genstef/dist/${P}-gentoo.patch.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND=">=sys-libs/pam-0.78-r3
19         >=app-admin/skey-1.1.5-r4"
20 RDEPEND="${DEPEND}"
21
22 S="${WORKDIR}/${PN}"
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         epatch "${WORKDIR}/${P}-gentoo.patch"
28 }
29
30 src_compile() {
31         econf --libdir="/$(get_libdir)" || die "econf failed"
32         emake || die "emake failed"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die "install failed"
37         dodoc README INSTALL
38 }
39
40 pkg_postinst() {
41         elog "To use this, you need to add something like"
42         elog
43         elog "auth       [success=done ignore=ignore auth_err=die default=bad] pam_skey.so"
44         elog "auth       sufficient   pam_unix.so likeauth nullok try_first_pass"
45         elog
46         elog "to appropriate place in /etc/pam.d/system-auth"
47         elog "Consult the documentation for instructions."
48 }