]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
sci-libs/rsl: Update to RSL 1.43
[~andy/sunrise] / sys-auth / pam_pgsql / pam_pgsql-1.0.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils pam
8
9 DESCRIPTION="A module for pam to authenticate users with PostgreSQL"
10 HOMEPAGE="http://pgfoundry.org/frs/?group_id=1000039"
11 SRC_URI="mirror://postgresql/projects/pgFoundry/sysauth/${PN/_/-}-${PV}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND=">=sys-libs/pam-0.78-r3
19         >=app-crypt/mhash-0.9.1
20         dev-db/postgresql-base"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${PN/_/-}
24
25 src_prepare() {
26         epatch "${FILESDIR}"/${PV}-gcc46.patch
27 }
28
29 src_install() {
30         insinto /etc
31         newins "${FILESDIR}/pam_pgsql.conf" pam_pgsql.conf || die "newins failed"
32         dopammod pam_pgsql.so
33         dodoc debian/changelog CREDITS README || die "dodoc failed"
34 }
35
36 pkg_postinst() {
37         einfo "From version 0.6 you can also use new style configuration (overrides"
38         einfo "legacy values). See /usr/share/doc/${PF}/README for more info."
39 }