]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
sys-auth/pam_pgsql - Version bump
[~andy/sunrise] / sys-auth / pam_pgsql / pam_pgsql-1.0.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit pam
6
7 DESCRIPTION="pam_pgsql is a module for pam to authenticate users with PostgreSQL"
8 HOMEPAGE="http://pgfoundry.org/frs/?group_id=1000039"
9 SRC_URI="mirror://postgresql/projects/pgFoundry/sysauth/${PN/_/-}-${PV}.tgz"
10 RESTRICT="mirror"
11
12 DEPEND=">=sys-libs/pam-0.78-r3
13         >=app-crypt/mhash-0.9.1
14         >=dev-db/postgresql-7.3.6"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86 ~amd64"
18
19 S="${WORKDIR}/${PN/_/-}"
20
21 src_unpack() {
22         unpack ${A} || die "unpack failed"
23 }
24
25 src_compile() {
26         econf || die "econf failed"
27         emake CFLAGS="${CFLAGS}" || die "emake failed"
28 }
29
30 src_install() {
31         insinto /etc
32         newins "${FILESDIR}/pam_pgsql.conf" pam_pgsql.conf
33         dopammod pam_pgsql.so
34         dodoc debian/changelog README CREDITS
35 }
36
37 pkg_postinst() {
38         einfo "From version 0.6 you can also use new style configuration (overrides"
39         einfo "legacy values). See /usr/share/doc/${PVR}/README for more info."
40 }