]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
sys-auth/pam_pgsql: Add missing autoconf dependencies
[~andy/sunrise] / sys-auth / pam_pgsql / pam_pgsql-1.0.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="2.1"
6 inherit pam autotools
7
8 DESCRIPTION="pam_pgsql is a module for pam to authenticate users with PostgreSQL"
9 HOMEPAGE="http://pgfoundry.org/frs/?group_id=1000039"
10 SRC_URI="mirror://postgresql/projects/pgFoundry/sysauth/${PN/_/-}-${PV}.tgz"
11 RESTRICT=""
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND=">=sys-libs/pam-0.78-r3
19         >=app-crypt/mhash-0.9.1
20         >=dev-db/postgresql-7.3.6"
21
22 RDEPEND="${DEPEND}"
23
24 S="${WORKDIR}/${PN/_/-}"
25
26 src_compile() {
27         econf || die "econf failed"
28         emake CFLAGS="${CFLAGS}" || die "emake failed"
29 }
30
31 src_install() {
32         insinto /etc
33         newins "${FILESDIR}/pam_pgsql.conf" pam_pgsql.conf
34         dopammod pam_pgsql.so
35         dodoc debian/changelog README CREDITS
36 }
37
38 pkg_postinst() {
39         elog "From version 0.6 you can also use new style configuration (overrides"
40         elog "legacy values). See /usr/share/doc/${PF}/README for more info."
41 }