]> Pileus Git - ~andy/sunrise/blob - sys-auth/oath-toolkit/oath-toolkit-1.10.5.ebuild
games-emulation/gr-lida: Properly fix qt deps
[~andy/sunrise] / sys-auth / oath-toolkit / oath-toolkit-1.10.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit pam
8
9 DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
10 HOMEPAGE="http://www.nongnu.org/oath-toolkit/"
11 SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
12 LICENSE="GPL-3 LGPL-2.1"
13
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="pam"
17
18 DEPEND="pam? ( virtual/pam )"
19 RDEPEND="${DEPEND}"
20
21 src_configure() {
22         econf $(use_enable pam) --with-pam-dir=$(getpam_mod_dir)
23 }
24
25 src_install() {
26         default
27         if use pam; then
28                 newdoc pam_oath/README README.pam
29         fi
30 }