]> Pileus Git - ~andy/sunrise/blob - sys-auth/google-authenticator/google-authenticator-1.0.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / sys-auth / google-authenticator / google-authenticator-1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs pam
8
9 DESCRIPTION="PAM Module for two step verification via mobile platform"
10 HOMEPAGE="http://code.google.com/p/google-authenticator/"
11 SRC_URI="http://${PN}.googlecode.com/files/libpam-${P}-source.tar.bz2"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="virtual/pam"
19
20 RDEPEND="${DEPEND}"
21
22 RESTRICT="test"
23 # Test fails with:
24 # pam_google_authenticator_unittest: pam_google_authenticator_unittest.c:317: main: Assertion `pam_sm_open_session(((void *)0), 0, targc, targv) == 0' failed.
25 # No user name available when checking verification code
26
27 S=${WORKDIR}/libpam-${P}
28
29 src_prepare(){
30         epatch "${FILESDIR}"/${P}-Makefile.patch
31         tc-export CC
32 }
33
34 src_install(){
35         dopammod pam_google_authenticator.so
36         dobin google-authenticator
37         dodoc README
38         dohtml totp.html
39 }
40
41 pkg_postinst(){
42         elog "For further information see"
43         elog "http://wiki.gentoo.org/wiki/Google_Authenticator"
44         elog ""
45         elog "If you want support for QR-Codes, install media-gfx/qrencode."
46 }