]> Pileus Git - ~andy/sunrise/blob - sys-apps/zidrav4unix/zidrav4unix-1.2.0.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / sys-apps / zidrav4unix / zidrav4unix-1.2.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="File corruption detection and repair program"
10 HOMEPAGE="http://sourceforge.net/projects/zidrav/"
11 SRC_URI="mirror://sourceforge/zidrav/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 src_prepare() {
19         sed -i \
20                 -e "s:g++:$(tc-getCXX):" \
21                 -e "s:-O2:${CXXFLAGS}:" \
22                 Makefile || die "sed Makefile failed"
23
24         epatch "${FILESDIR}"/${PV}-gcc46.patch
25 }
26
27 src_install() {
28         dobin zidrav
29         doman zidrav.1
30         dodoc README TODO Changelog zidrav.txt
31 }