]> Pileus Git - ~andy/sunrise/blob - sys-apps/zidrav4unix/zidrav4unix-1.2.0.ebuild
sys-apps/ksplice: Make dodoc die on failure
[~andy/sunrise] / sys-apps / zidrav4unix / zidrav4unix-1.2.0.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="File corruption detection and repair program"
8 HOMEPAGE="http://sourceforge.net/projects/zidrav/"
9 SRC_URI="mirror://sourceforge/zidrav/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 src_unpack() {
17         unpack ${A}
18         cd "${S}"
19         sed -i \
20                 -e "s:g++:$(tc-getCXX):" \
21                 -e "s:-O2:${CXXFLAGS}:" \
22                 Makefile || die "sed Makefile failed"
23 }
24
25 src_install() {
26         dodoc README TODO Changelog zidrav.txt
27         doman zidrav.1
28         dobin zidrav
29 }