]> Pileus Git - ~andy/sunrise/blob - sys-apps/ultracopier/ultracopier-0.2.0.9.ebuild
b69be061050a8b0dd28600f3bd22d6a54122dae2
[~andy/sunrise] / sys-apps / ultracopier / ultracopier-0.2.0.9.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils qt4-r2
8
9 DESCRIPTION="Advanced file copying tool"
10 HOMEPAGE="http://ultracopier.first-world.info/"
11 SRC_URI="http://files.first-world.info/${PN}/${PV}/ultracopier-src-${PV}.tar.bz2 -> ${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc64 ~x86"
16 IUSE="debug"
17 S="${WORKDIR}/${P}/src/"
18
19 RDEPEND="x11-libs/qt-core:4
20         x11-libs/qt-gui:4"
21 DEPEND="${RDEPEND}"
22
23 src_prepare() {
24         if use debug ; then
25                 sed -i -r 's/DEBUG_ULTRACOPIER [0-9]+/DEBUG_ULTRACOPIER 100/g' var.h || die "Error when set the debug level"
26         else
27                 sed -i -r 's/DEBUG_ULTRACOPIER [0-9]+/DEBUG_ULTRACOPIER 0/g' var.h || die "Error when set the debug level"
28         fi
29 }
30
31 src_install() {
32         rm -f lang/fr* lang/en* lang/*.ts
33         rm -Rf styles/kde3/
34         dobin ultracopier || die "Error when copy the application"
35         newicon other/ultracopier-128x128.png ultracopier.png || die "Error when copy the icon"
36         domenu other/ultracopier.desktop || die "Error when copy the shortcut"
37         insinto /usr/share/ultracopier/ || die "Error when switch of directory"
38         doins -r lang/ styles/ || die "Error when copy language and styles"
39 }