]> Pileus Git - ~andy/sunrise/blob - sys-apps/remendeko/remendeko-0.3.0.ebuild
sys-apps/remendeko - Fix quotes.
[~andy/sunrise] / sys-apps / remendeko / remendeko-0.3.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_PN="RemenDeKO"
6 DESCRIPTION="File corruption detection and repair program"
7 HOMEPAGE="http://rdko.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/rdko/${MY_PN}-${PV}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~x86"
13 IUSE="gtk"
14 RESTRICT="strip"
15
16 RDEPEND="gtk? ( >=x11-libs/gtk+-2.4.0 )"
17
18 DEPEND="${RDEPEND}
19         >=dev-util/pkgconfig-0.15"
20
21 S="${WORKDIR}/${MY_PN}"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26
27         sed -i \
28                 -e '/^CFLAGS =/s:-fmessage-length=0 -fexpensive-optimizations -O3:$(E_CFLAGS):' \
29                 -e '/^CFLAGSGUI/s:-fmessage-length=0 -fexpensive-optimizations -O3:$(CFLAGS):' \
30                 Makefile || die "sed Makefile failed"
31 }
32 src_compile() {
33         if use gtk; then
34                 emake E_CFLAGS="${CFLAGS}"  || die "emake failed"
35         else
36                 emake E_CFLAGS="${CFLAGS}" rdko || die "emake failed"
37         fi
38 }
39
40 src_install() {
41         dodoc CHANGELOG
42         dobin rdko || die "dobin rdko failed"
43         if use gtk; then
44                 dobin gredeko || die "dobin gredeko failed"
45         fi
46 }