]> Pileus Git - ~andy/sunrise/blob - sys-apps/pacman/pacman-3.3.3.ebuild
sys-apps/pacman: Add missing runtime dep on xz-utils. Fix ./configure flags. Refer...
[~andy/sunrise] / sys-apps / pacman / pacman-3.3.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit autotools
8
9 DESCRIPTION="archlinux's binary package manager"
10 HOMEPAGE="http://archlinux.org/pacman/"
11 SRC_URI="ftp://ftp.archlinux.org/other/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="debug doc test"
17
18 COMMON_DEPEND="app-arch/libarchive
19         virtual/libiconv
20         virtual/libintl
21         sys-devel/gettext"
22 RDEPEND="${COMMON_DEPEND}
23         app-arch/xz-utils"
24 DEPEND="${COMMON_DEPEND}
25         doc? ( app-doc/doxygen )
26         test? ( dev-lang/python )"
27
28 src_prepare() {
29         sed -i -e '/-Werror/d' configure.ac || die "-Werror"
30         # acinclude.m4 overrides libtool macros from /usr/share/aclocal, causing
31         # elibtoolize's ltmain.sh to incompatible with ./configure after
32         # eautoreconf is run.
33         sed -i -e '4,/dnl Add some custom macros for pacman and libalpm/d' acinclude.m4 || die "libtool fix"
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 --localstatedir=/var \
40                 --disable-git-version \
41                 --disable-internal-download \
42                 $(use_enable debug) \
43                 $(use_enable doc) \
44                 $(use_enable doc doxygen)
45 }
46
47 src_install() {
48         emake DESTDIR="${D}" install || die
49
50         dodir /etc/pacman.d || die
51 }
52
53 pkg_postinst() {
54         einfo "Please see http://ohnopub.net/~ohnobinki/gentoo/arch/ for information"
55         einfo "about setting up an archlinux chroot."
56 }