]> Pileus Git - ~andy/sunrise/blob - sys-apps/gdivelog/gdivelog-0.5.1.ebuild
app-misc/autokey-gtk: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / sys-apps / gdivelog / gdivelog-0.5.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="SCUBA dive logging application, with extendable plugin support"
6 HOMEPAGE="http://gdivelog.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/gdivelog/${P}.tar.bz2"
8
9 LICENSE="GPL-3"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=">=gnome-base/libgnomeui-2.10
15         >=dev-db/sqlite-3.1.2"
16 RDEPEND="${DEPEND}"
17
18 # Configure Options from http://scratchpad.wikia.com/wiki/Installing_gdivelog I haven't checked or added yet.
19 #--enable-all-plugins
20 #--enable-plugin-dump
21 #--disable-utils
22 #--disable-mdbtools          # needs to be added, don't want to overwrite the regular mdbtools which resides in portage
23 #--with-mdbtools=DIR
24 #--enable-smart-plugin       # smart needs IrDA kernel support and/or irda.h header file avalible to compile
25 #--enable-smarttrak-plugin   # relies on MDB tools, patched?
26 #--enable-suuntodm2-plugin   # relies on a patched version of MDB tools
27 # BUGS
28 #* When installing a plugin I get a duplicate in the application list, upstream?
29
30 src_install() {
31         emake DESTDIR="${D}" install || die "emake install failed"
32 }
33
34 pkg_postinst() {
35         elog "For extendable plugins support just emerge the appropriate ebuild"
36         elog ""
37         elog "x11-plugins/gdivelog-hyperaqualand-plugin         Citizen Hyperaqualand."
38         elog "x11-plugins/gdivelog-sensuspro-plugin                     Reefnet Sensus Pro."
39         elog "x11-plugins/gdivelog-suunto-plugin                        Suunto Cobra, Mosquito, Spyder, Stinger, Vyper and Vytec."
40         elog ""
41 }