]> Pileus Git - ~andy/sunrise/blob - sys-apps/fspy/fspy-0.1.1.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / sys-apps / fspy / fspy-0.1.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Easy to use filesystem activity monitoring"
8 HOMEPAGE="http://mytty.org/fspy/"
9 SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 src_compile() {
17         local cc=$(tc-getCC)
18
19         emake clean || die
20         # LDFLAGS var is passed when compiling too...
21         emake CC="${cc}" LD="${cc} ${LDFLAGS}" || die
22 }
23
24 src_install() {
25         dobin fspy || die "failed to install fspy binary"
26         dodoc README || die "failed to install documentation"
27 }