]> Pileus Git - ~andy/sunrise/blob - sys-apps/evrouter/evrouter-0.4.ebuild
36f75bee1c13e9db238de5ad17539dff8ae6b5ae
[~andy/sunrise] / sys-apps / evrouter / evrouter-0.4.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils autotools
6
7 DESCRIPTION="An input event router"
8 HOMEPAGE="http://www.bedroomlan.org/~alexios/coding_evrouter.html"
9
10 SRC_URI="http://debian.bedroomlan.org/debian/pool/main/e/${PN}/${PN}_${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND="x11-libs/libX11
18                 x11-libs/libXext
19                 x11-libs/libxcb
20                 x11-libs/libXau
21                 x11-libs/libXdmcp"
22
23 RDEPEND="${DEPEND}"
24
25 S=${WORKDIR}/${PF}
26
27 src_unpack() {
28         unpack ${A}
29         cd "${S}"
30         eautoreconf
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die
35         dodoc src/example || die
36 }