]> Pileus Git - ~andy/sunrise/blob - sys-apps/evemu/evemu-1.0.10.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / sys-apps / evemu / evemu-1.0.10.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python2_{6,7} )
8
9 inherit autotools eutils python-single-r1
10
11 DESCRIPTION="Tools and bindings for kernel input event device emulation, data capture and replay"
12 HOMEPAGE="https://launchpad.net/evemu"
13 SRC_URI="http://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.gz"
14
15 LICENSE="LGPL-3 GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="static-libs"
19
20 RDEPEND="${PYTHON_DEPS}"
21 DEPEND="app-text/asciidoc
22         app-text/xmlto
23         ${RDEPEND}"
24
25 src_prepare() {
26         # add --disable-werror flag - upstream bug: https://bugs.launchpad.net/evemu/+bug/1095836
27         epatch "${FILESDIR}"/${P}-werror.patch
28         eautoreconf
29
30         sed -e "s|${PN}|man1/${PN}|" -i tools/${PN}-record.1 tools/${PN}-play.1 || die
31 }
32
33 src_configure() {
34         econf \
35                 --disable-werror \
36                 $(use_enable static-libs static)
37 }
38
39 src_install() {
40         default
41         use static-libs || prune_libtool_files
42 }