]> Pileus Git - ~andy/sunrise/blob - sys-apps/cfnrename/cfnrename-0.2.ebuild
New cFnRename ebuild for bug 45907
[~andy/sunrise] / sys-apps / cfnrename / cfnrename-0.2.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="A simple utility that allows you to easily rename multiple files."
6 HOMEPAGE="http://home.hccnet.nl/paul.schuurmans/linux/"
7 SRC_URI="http://home.hccnet.nl/paul.schuurmans/linux/download/${P}.tar.gz"
8 LICENSE="GPL-2"
9
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=">=sys-libs/ncurses-5.3"
15
16 src_unpack() {
17         unpack ${A}
18         cd "${S}"
19
20         # Replace the CFLAGS with our own custom CFLAGS
21         sed -i -e "/^CFLAGS =/s:-g:${CFLAGS}:" \
22                 Makefile || die "sed Makefile failed"
23 }
24
25 src_install() {
26         dodoc AUTHORS README TODO ChangeLog
27         dobin cfnrename
28 }