]> Pileus Git - ~andy/sunrise/blob - sci-visualization/som_pak/som_pak-3.1.ebuild
dev-libs/libserial: Adding ~amd64 keyword
[~andy/sunrise] / sci-visualization / som_pak / som_pak-3.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="The Self-Organizing Map Program Package"
8 HOMEPAGE="http://www.cis.hut.fi/research/som-research/nnrc-programs.shtml"
9 SRC_URI="http://www.cis.hut.fi/research/${PN}/${P}.tar"
10
11 SLOT="0"
12 LICENSE="free-noncomm"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         epatch "${FILESDIR}"/${P}_makefile_qa.diff
24 }
25
26 src_compile() {
27         emake -f makefile.unix || die "emake failed"
28 }
29
30 src_test() {
31         # is this really a "test"?
32         emake -f makefile.unix example || die "emake examples failed"
33 }
34
35 src_install() {
36         dobin lininit mapinit planes qerror randinit sammon umat vcal vfind visual vsom
37         dodoc README
38 }