]> Pileus Git - ~andy/sunrise/blob - sci-visualization/jps2ps/jps2ps-0.18.ebuild
dev-util/qshaderedit: Properly fix qt deps
[~andy/sunrise] / sci-visualization / jps2ps / jps2ps-0.18.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit multilib
6
7 DESCRIPTION="A small perl script for the creation of mathematic images in PostScript."
8 HOMEPAGE="http://syracuse.eu.org/syracuse/bbgraf/"
9
10 SRC_URI="http://syracuse.eu.org/syracuse/bbgraf/archives/${P/./-}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 RDEPEND="dev-lang/perl
18         app-text/ghostscript-gpl"
19
20 src_install() {
21         insinto /usr/$(get_libdir)/syracuse/app
22
23         doins -r "${WORKDIR}"/jps2ps || die
24
25         # Fix permissions
26         fperms guo=rx /usr/$(get_libdir)/syracuse/app/jps2ps/{jps2ps,filtre-file,jpshash,exp2rpn,lit_appels,lit_cles}.pl
27
28         # Fix the variable JPS2PS_DIR defined inside the perl script
29         # so it points to the right directory.
30         # Based on the dev-lang/R ebuild regexp.
31         sed \
32                 -e "/^\$JPS2PS_DIR = .*/s::\$JPS2PS_DIR = \"/usr/$(get_libdir)/syracuse/app/jps2ps/\";:" \
33                 -i "${D}"/usr/$(get_libdir)/syracuse/app/jps2ps/jps2ps.pl \
34                 || die "sed failed."
35
36         dosym /usr/$(get_libdir)/syracuse/app/jps2ps/jps2ps.pl /usr/bin/jps2ps
37 }