]> Pileus Git - ~andy/sunrise/blob - sci-visualization/jps2ps/jps2ps-0.15.ebuild
Cosmetics
[~andy/sunrise] / sci-visualization / jps2ps / jps2ps-0.15.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit multilib
6
7 DESCRIPTION="A small perl script for the creation of mathematic images in PostScript."
8 HOMEPAGE="http://syracuse.eu.org/syracuse/bbgraf/"
9
10 SRC_URI="http://syracuse.eu.org/syracuse/bbgraf/archives/${PN}-0-15.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND="${DEPEND}
19         dev-lang/perl
20         virtual/ghostscript"
21
22 src_install() {
23         dodir /usr/$(get_libdir)/syracuse/app/jps2ps/{pps,package}
24
25         insinto usr/$(get_libdir)/syracuse/app
26         doins -r "${WORKDIR}"/jps2ps
27
28         exeinto usr/$(get_libdir)/syracuse/app/jps2ps
29         doexe "${WORKDIR}"/jps2ps/{jps2ps,filtre-file,jpshash,exp2rpn,lit_appels,lit_cles}.pl
30
31         # Fix the variable JPS2PS_DIR defined inside the perl script
32         # so it points to the right directory.
33         # Based on the dev-lang/R ebuild regexp.
34         sed \
35                 -e "/^\$JPS2PS_DIR = .*/s::\$JPS2PS_DIR = \"/usr/$(get_libdir)/syracuse/app/jps2ps/\";:" \
36                 -i ${D}/usr/$(get_libdir)/syracuse/app/jps2ps/jps2ps.pl \
37                 || die "sed failed."
38
39         dosym /usr/$(get_libdir)/syracuse/app/jps2ps/jps2ps.pl /usr/bin/jps2ps
40 }