]> Pileus Git - ~andy/sunrise/blob - sci-mathematics/javanns/javanns-1.1.ebuild
app-editors/yzis: Fix qt deps, EAPI bump
[~andy/sunrise] / sci-mathematics / javanns / javanns-1.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit java-pkg-2
6
7 DESCRIPTION="an efficient universal simulator of neural networks"
8 HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/software/JavaNNS/welcome_e.html"
9 SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/JavaNNS/${P}-src.zip"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 RDEPEND=">=virtual/jre-1.4"
17 DEPEND="${RDEPEND}
18         >=virtual/jdk-1.4
19         app-arch/unzip
20         dev-java/ant"
21
22 MY_PN="JavaNNS"
23
24 S="${WORKDIR}/${MY_PN}"
25
26 src_unpack() {
27         unpack ${A}
28         cp "${FILESDIR}/target.def" "${S}/"
29         cd "${S}"
30         rm manual/*.pdf
31 }
32
33 src_install() {
34         java-pkg_dojar dist/JavaNNS.jar
35
36         java-pkg_dolauncher ${MY_PN}
37
38         dodoc COPYRIGHT.txt
39         dohtml manual/*
40 }
41
42 pkg_postinst() {
43         elog "In order to be able to use the User Manual from within the"
44         elog "simulator, you may have to adjust some of the JavaNNS properties."
45         elog "Use View/Properties menu in JavaNNS and consult the User Manual for"
46         elog "further details."
47 }