]> Pileus Git - ~andy/sunrise/blob - sci-mathematics/alberta/alberta-1.2.1.ebuild
0b6951c35b8aeb0b835189d13ffcc87177fc45de
[~andy/sunrise] / sci-mathematics / alberta / alberta-1.2.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="An adaptive hierarchical finite element toolbox"
8 HOMEPAGE="http://www.alberta-fem.de/"
9 SRC_URI="http://www.alberta-fem.de/Downloads/${P/.1}.tar.gz
10         http://gentooexperimental.org/~genstef/dist/${P}.patch.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="virtual/blas
18         virtual/opengl"
19
20 S="${WORKDIR}/${P/.1}"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         # A working version of the 1.2.1 patch provided by upstream
26         epatch "${WORKDIR}/${P}.patch"
27 }
28
29 src_compile() {
30         # There exists no ebuild for gltools nor grape, disabling it
31         econf \
32                 --without-gltools \
33                 --without-grape || die "econf failed"
34         emake || die "emake failed"
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install || die "emake install failed"
39         dodoc README THANKS AUTHORS NEWS
40 }