]> Pileus Git - ~andy/sunrise/blob - sci-libs/rsl/rsl-1.40.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / sci-libs / rsl / rsl-1.40.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils autotools
8
9 DESCRIPTION="Radar Software Library"
10 HOMEPAGE="http://trmm-fc.gsfc.nasa.gov/trmm_gv/software/rsl/index.html"
11 SRC_URI="ftp://trmm-fc.gsfc.nasa.gov/software/${PN}-v${PV}.tar.gz"
12
13 LICENSE="LGPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 RDEPEND="sci-libs/hdf
19         media-libs/jpeg"
20 DEPEND="${RDEPEND}"
21
22 S="${WORKDIR}/rsl-v${PV}"
23
24 src_prepare() {
25         epatch "${FILESDIR}/${PN}-"{warnings,automake,type_str,valgrind}".patch"
26         eautoreconf
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install || die "install failed"
31         dodoc README CHANGES || die
32 }