]> Pileus Git - ~andy/sunrise/blob - sci-libs/pygrib/pygrib-1.8.1.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / sci-libs / pygrib / pygrib-1.8.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit eutils distutils
11
12 DESCRIPTION="Python module for reading and writing GRIB files (edition 1 and edition 2)"
13 HOMEPAGE="http://code.google.com/p/pygrib/ http://pypi.python.org/pypi/pygrib/"
14 SRC_URI="http://pygrib.googlecode.com/files/${P}.tar.gz"
15
16 LICENSE="pygrib"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="doc"
20
21 RDEPEND="dev-python/numpy
22         sci-libs/proj
23         dev-python/matplotlib
24         dev-python/basemap
25         sci-libs/grib_api
26         || ( media-libs/jasper media-libs/openjpeg )
27         media-libs/libpng
28         sys-libs/zlib"
29 DEPEND="${RDEPEND}"
30
31 src_prepare() {
32 # patch already be applied by upstream, avoid conflict with grib_api's script
33 # ref http://code.google.com/p/pygrib/issues/detail?id=22
34         epatch "${FILESDIR}"/${P}-fix_duplicate_name.patch
35 }
36
37 src_install() {
38         distutils_src_install
39
40         if use doc; then
41                 dohtml docs/* || die
42         fi
43 }