]> Pileus Git - ~andy/sunrise/blob - sci-libs/nurbs++/nurbs++-3.0.11.ebuild
64d7ca2b3631d68159cb4e95a4081f28d34e1ac1
[~andy/sunrise] / sci-libs / nurbs++ / nurbs++-3.0.11.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit libtool eutils
6
7 DESCRIPTION="This C++ library provides the basic methods for Non-Uniform Rational B-Splines (NURBS)."
8 HOMEPAGE="http://libnurbs.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/libnurbs/${P}.tar.bz2
10         http://dev.gentooexperimental.org/~jokey/sunrise-dist/${P}-gcc-4.1.patch.bz2"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="debug"
16
17 DEPEND="dev-lang/perl"
18 RDEPEND=""
19
20 src_unpack() {
21         unpack ${A}
22         cd "${S}"
23         epatch "${DISTDIR}"/${P}-gcc-4.1.patch
24         elibtoolize
25 }
26
27 src_compile() {
28         econf \
29                 --without-x \
30                 $(use_enable debug) \
31                 $(use_enable debug verbose-exception) \
32
33         emake || die "emake failed!"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed!"
38         dodoc AUTHORS ChangeLog NEWS README
39 }