]> Pileus Git - ~andy/sunrise/blob - sci-libs/libticonv/libticonv-20061030.ebuild
sci-libs/libticonv: Version bump
[~andy/sunrise] / sci-libs / libticonv / libticonv-20061030.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="charset conversion library for TI calculators"
8 HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
9 SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="nls"
15
16 DEPEND=">=dev-libs/glib-2
17         nls? ( sys-devel/gettext )"
18
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${PN}
22
23 src_compile() {
24         econf $(use_enable nls) || die "econf failed"
25         emake || die "emake failed"
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install || die "emake install failed"
30         dodoc AUTHORS LOGO NEWS README ChangeLog docs/api.txt
31         dohtml docs/html/*
32         docinto charsets
33         dohtml docs/charsets/*
34 }