]> Pileus Git - ~andy/sunrise/blob - sci-libs/libquantum/libquantum-1.1.0.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / sci-libs / libquantum / libquantum-1.1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="C library for quantum computing and quantum simulation"
8 HOMEPAGE="http://www.libquantum.de/"
9 SRC_URI="http://www.libquantum.de/files/${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~sparc ~x86"
14 IUSE="+lapack examples profile"
15
16 DEPEND="lapack? ( virtual/lapack )"
17 RDEPEND="${DEPEND}"
18
19 src_configure() {
20         econf \
21                 $(use_with lapack) \
22                 $(use_enable profile profiling)
23 }
24
25 src_compile() {
26         emake || die
27         emake quobtools || die
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" install || die
32         emake DESTDIR="${D}" quobtools_install || die
33         dodoc CHANGES || die
34         if use examples ; then
35                 docinto examples/
36                 newdoc INSTALL INSTALL.how_to_compile_own_stuff || die
37                 dodoc shor.c grover.c || die
38         fi
39 }