]> Pileus Git - ~andy/sunrise/blob - sci-chemistry/bist/bist-0.5.1-r1.ebuild
2a31a618c0ea3834357bb083e0fef030c6f171e9
[~andy/sunrise] / sci-chemistry / bist / bist-0.5.1-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils base
8
9 DESCRIPTION="Bist, the chemical drawing tool"
10 HOMEPAGE="http://www.autistici.org/interzona/index.php?mod=03_Bist"
11 SRC_URI="http://www.autistici.org/interzona/ftrack.php?url=sections/06_Download/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="net-misc/curl
19         dev-libs/expat
20         >=x11-libs/fltk-1.1.7:1.1
21         sci-libs/gsl
22         >=sci-chemistry/openbabel-2.2.0
23         >=media-libs/plotutils-2.5"
24
25 DEPEND="${RDEPEND}"
26
27 src_prepare() {
28         use amd64 && epatch "${FILESDIR}/${P}-bracket.patch"
29         epatch "${FILESDIR}/${P}-install.patch"
30 }