]> Pileus Git - ~andy/sunrise/blob - sci-biology/twinscan/twinscan-4.1.2.ebuild
7a1e3f1ca554a5791cdcc52c428a18ee4c6d2d82
[~andy/sunrise] / sci-biology / twinscan / twinscan-4.1.2.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="TwinScan, N-SCAN, and Pairagon: A gene structure prediction pipeline"
6 LICENSE="as-is"
7 HOMEPAGE="http://mblab.wustl.edu/software/twinscan"
8 SLOT="0"
9 IUSE=""
10 KEYWORDS="~x86"
11 SRC_URI="http://mblab.wustl.edu/software/download/iscan-${PV}.tar_.gz"
12
13 S="${WORKDIR}/N-SCAN"
14
15 RDEPEND="sci-biology/repeatmasker"
16
17 src_unpack() {
18         unpack ${A}
19         tar -C "${WORKDIR}" -xf iscan-${PV}.tar_
20         sed -i "s|\(use strict;\)|\1\nuse lib \"/usr/share/${PN}/lib/perl5\";|" "${S}"/bin/*.pl || die
21 }
22
23 src_install() {
24         dobin "${S}/bin/iscan"
25         dobin "${S}/bin/"*".pl"
26         insinto /usr/share/${PN}
27         doins -r "${S}/parameters"
28         doins -r "${S}/lib"
29         dodoc examples/* README*
30 }